Edea Ice Fly--slight foot problem

sashavis

Rinkside
Joined
Oct 27, 2020
Country
United-States
Hi everyone.

I recently purchased a new pair of Ice Flies (my old ones had broken down), and I've had excruciating pain in my right foot along the bone on the left hand side. These are the exact same boots as last time, and I absolutely adore them, but I'm just not certain what to do about this pain. I have a small blister that is mostly healed, so something is clearly rubbing, but does anyone have any recommendations? I'm thinking maybe I put my arch insert in the boot in such a way that perhaps is different to my last pair? Nothing has changed with the boots since the last pair--the size is still the same, same make on the tongue, everything. I've only had them for a week, so maybe I just need to keep molding them to my feet? The pain isn't caused by the tongue, either, but rather the side of the boot near the bottom lace hook on the left side. The pain is awful, and I will probably go see my tech and ask him about this, but I won't be able to make it to him for a bit so I'm wondering if anyone here has advice.

Thank you all so much!!
 

WednesdayMarch

On the Ice
Joined
Mar 24, 2019
Country
United-Kingdom
Have you tried looking and feeling inside the boot to see if there's something visible that could be causing the problem? Take the innersole out, too and check.
 

sashavis

Rinkside
Joined
Oct 27, 2020
Country
United-States
I have! There doesn't seem to be anything inside, and I've taken the innersoles out a few times to try and rearrange the gel arch supports that I have in there to see if that helped at all. So far, that hasn't helped much. I can see where the spot that is rubbing is though (there is a bit of discoloration because I bled a bit), but I think I might just play around with the positioning of my gel inserts for a bit longer.
 

gliese

On the Ice
Joined
Oct 31, 2020
Country
United-States
I have been having a similar problem in Pianos. I'm seeing my tech on Wednesday and can let you know what to look for. It could very well be your arch inserts. I have some too and I think they are causing my problem.
 
Top